Federationtrust für Exchange Hybrid Umgebung lässt sich nicht einrichten

Kleine Abenteuer  mit Proxyserver Einstellungen beim Einrichten einer Exchange Hybrid Umgebung!

Bei Einrichten einer Exchange Hybrid Umgebung warf der Assistent eine Fehlermeldung beim Erstellen des Federationtrust zum Microsoft Federation Gateway aus:

„Auf das Verbundmetadatendokument kann nicht vom Verbundpartner aus zugegriffen werden. Der Remotename konnte nicht aufgelöst werden: ‚tmgv01.mydom.local’“.

Na ja: Der Remote Connectivity Analyser von Microsoft ergab für den Test der Exchange Webservices mit Autodiscover keinen Fehler.

Das Rätsel: Wer ist tmgv01.mydom.local? Jedenfalls war das kein Exchange Server.  Der Name wurde im DNS nicht aufgelöst, was ja nach der Fehlermeldung eigentlich klar war. Das im AD vorhandene Computer war seit x Jahren nicht mehr aktiv.

Die Recherche im Internet ließ vermuten, dass ein Proxyserver seine Finger im Spiel haben könnte. Dafür waren die folgenden Einstellungen zu überprüfen:

Get-exchangeServer | fl name,internetwebproxy

und

Netsh winhttp show proxy

Beides ergab, dass kein Proxyserver eingestellt war.

Im Internet Explorer gab es auch keine Proxyserver Einstellungen. Der Zugriff auf das Verbundmetadatendokument war übrigens mit den Browser möglich. Die URL dazu ist im Active Directory in folgendem Objekt im Attribut ServiceBindingInformation zu  finden:

  • CN=MsoFederationMetadata,CN=ServiceEndpoints,CN=ExchangeMyDom,CN=Microsoft Exchange,CN=Services,CN=Configuration,dc=mydom,dc=local

(CN=ExchangeMyDom und dc=mydom,dc=local müssen durch die jeweiligen passenden Werte ersetzt werden.)

Die URL für das Verbunddatendokument: https://nexus.microsoftonline-p.com/FederationMetadata/2006-12/FederationMetadata.xml

Im Browser – Sitzung auf einem Exchange Server – wurde das XML-Dokument angezeigt.

Also?

Der nächste Schritt war, die Registrierung der Exchange Server zu durchsuchen. Suche nach tmgv01.mydom.local‘ – Bingo:

In HKEY_Users gab es  Treffer:

  • HKEY_Users\.Default\Software\Microsoft\Windows\CurrentVersion\Internet Settings

Dort gab es Einträge für die Proxyserver Einstellungen und den Subkey Connections. Der Proxyservername war auf tmgvm01.mydom.local festgelegt und aktiviert. Ich habe alle Einträge den Proxyserver (proxyservername, proxyenabled) betreffend und den Subkey Connections gelöscht.

Der Hybrid-Assistent konnte den Federationtrust und die Hybrid Konfiguration erfolgreich einrichten. 

Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn
Share on pinterest
Pinterest
Share on email
Email

Kommentar verfassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Scroll to Top